Mail delays
Incident Report for MediaLab
Resolved
The mail platform is back up and running and the pending queue has been processed. This issue is now resolved and maintenance finished.
Posted 4 months ago. Jun 19, 2019 - 20:20 CEST
Identified
We are currently experiencing delays on our mailing platform due to platform maintenance. Mails will be queued until the full system is back up, which we expect to be within the hour.

We will provide an update no later than 18:30 GMT
Posted 4 months ago. Jun 19, 2019 - 19:27 CEST
This incident affected: Platform.